Sherin Abdel Hamid @sahamid ?

active 5 years, 2 months ago
"Hello, I’m trying to run the demo but I got this error ********************** SETUP PHASE ENDS HERE. iCS –> Global simulation timestep is: 0; last step is: 3000 ============================================================ STEP 5 – SIMULATION PHASE – Tics = 0 STEP 6 [...]" · View
  • Sherin Abdel Hamid and Julen Maneros are now friends   8 years, 5 months ago · View

  • Sherin Abdel Hamid posted a new activity comment:   8 years, 6 months ago · View

    The linux version is ubuntu 10.04 and the NS-3 version is 3.7

    In reply to - Sherin Abdel Hamid posted an update: Hello, I’m trying to run the demo but I got this error ********************** SETUP PHASE ENDS HERE. iCS –> Global simulation timestep is: 0; last step is: 3000 ============================================================ STEP 5 – SIMULATION PHASE – Tics = 0 STEP 6 – SIMULATION PHASE – Tics = 0 Step #0.00Warning: period [...] · View
  • Sherin Abdel Hamid posted a new activity comment:   8 years, 6 months ago · View

    Hi Hanno,

    Thank you so much for your reply. I’ve tried many sumo versions and finally had it work with sumo-0.12.3. Now, I’m stuck with another error but in a later step

    STEP 8 – SIMULATION PHASE – Tics = 100
    GeoRoutingProtocol: RouteOutput => geounicast
    UTILS: distance of neighbor 0 to destination = 13.1529
    UTILS: the min dist to dest = 13.1529 and is provided by node 0
    iCS –> [ERROR] ProcessApplicationResults()

    ns-3 server –> Finishing server….

    Success.
    Elapsed time (in seconds): 242.000000
    Error: Socket exception: tcpip::Socket::receive() @ recv: Success
    Step #101.00 (2ms ~= 500.00*RT, ~21500.00UPS, vehicles TOT 57 ACT 43)

    could you please help me with that?

    Thank you

    In reply to - Sherin Abdel Hamid posted an update: Hello, I’m trying to run the demo but I got this error ********************** SETUP PHASE ENDS HERE. iCS –> Global simulation timestep is: 0; last step is: 3000 ============================================================ STEP 5 – SIMULATION PHASE – Tics = 0 STEP 6 – SIMULATION PHASE – Tics = 0 Step #0.00Warning: period [...] · View
  • Sherin Abdel Hamid posted a new activity comment:   8 years, 6 months ago · View

    Hi Lukas,
    I’m stuck with the same problem, did you manage to solve it?

    In reply to - Lukas-Worle posted an update in the group Bug reports : I experienced the following problem while running the iCS demo application: iCS –> Global simulation timestep is: 99; last step is: 3000 ================================================ STEP 5 – SIMULATION PHASE – Tics = 99 STEP 6 – SIMULATION PHASE – Tics = 99 0.000000 0.000000 STEP 7 – SIMULATION PHASE [...] · View
  • Sherin Abdel Hamid and Hanno-Spijker are now friends   8 years, 6 months ago · View

  • Sherin Abdel Hamid posted an update:   8 years, 6 months ago · View

    Hello,

    I’m trying to run the demo but I got this error

    **********************
    SETUP PHASE ENDS HERE.

    iCS –> Global simulation timestep is: 0; last step is: 3000
    ============================================================
    STEP 5 – SIMULATION PHASE – Tics = 0
    STEP 6 – SIMULATION PHASE – Tics = 0
    Step #0.00Warning: period and repno are deprecated in vehicle ’1-4’, use flows instead.
    Error: The vehicle type ’dist’ for vehicle ’1-4’ is not known.
    Quitting (on error).
    iCS –> #Error while receiving command from SUMO: tcpip::Socket::receive() @ recv: Success
    iCS –> [ERROR] RunOneSumoTimeStep()
    ns-3 server –> Finishing server….
    iCS –> #Error while receiving command: tcpip::Socket::receive() @ recv: Success
    iCS –> [ERROR] CloseSumo() Closing SUMO

    Success.
    Elapsed time (in seconds): 43.000000
    Error: Socket exception: tcpip::Socket::receive() @ recv: Success

    Any suggestions? your help will be greatly appreciated

    • Avatar Image
      Sherin Abdel Hamid · 8 years, 6 months ago

      Hi Hanno,

      Thank you so much for your reply. I’ve tried many sumo versions and finally had it work with sumo-0.12.3. Now, I’m stuck with another error but in a later step

      STEP 8 – SIMULATION PHASE – Tics = 100
      GeoRoutingProtocol: RouteOutput => geounicast
      UTILS: distance of neighbor 0 to destination = 13.1529
      UTILS: the min dist to dest = 13.1529 and is provided by node 0
      iCS –> [ERROR] ProcessApplicationResults()

      ns-3 server –> Finishing server….

      Success.
      Elapsed time (in seconds): 242.000000
      Error: Socket exception: tcpip::Socket::receive() @ recv: Success
      Step #101.00 (2ms ~= 500.00*RT, ~21500.00UPS, vehicles TOT 57 ACT 43)

      could you please help me with that?

      Thank you

  • Sherin Abdel Hamid joined the group Bug reports   8 years, 6 months ago · View

  • Sherin Abdel Hamid joined the group iTetris Custom Application Development   8 years, 6 months ago · View

  • Sherin Abdel Hamid posted a new activity comment:   8 years, 6 months ago · View

    Hello,

    I had the same problem and managed to get ns3 and app connected but now I get this error

    STEP 4 – SETUP PHASE
    Error: Answered with error to command 8 Wrong position in requestMessage after dispatching command. Expected command length was 28 but 14 Bytes were read.
    .. Sent command is not implemented (8), [description: ]
    iCS –> [ERROR] SetFixedStationInNs3() Error in the message to create fixed station in ns-3
    iCS –> ERROR setting fixed stations in ns-3

    Step #0.00Warning: period and repno are deprecated in vehicle ’1-4’, use flows instead.
    iCS –> #Error while receiving command: tcpip::SocketNs3::receive() @ recv: SuccessiCS –> [ERROR] CloseNs3() Finishing NS-3
    iCS –> Error occurred during iCS set-up
    Quitting (on error).
    Elapsed time (in seconds): 3.000000
    shereen@ubuntu:~/iTETRIS_Platform_0.1.0/its_demo_app_0.1.0/example$ Error: The vehicle type ’dist’ for vehicle ’1-4’ is not known.
    Quitting (on error).

    any suggestion? your help will be greatly appreciated

    In reply to - Lukas-Worle posted an update in the group Setup Support : Some issues about the ITS Cooperative Demo Application: I needed to run the configure command again with the additional xerces-path: ./configure –with-xerces-libraries=”/usr/local/lib -lxerces-c” in src/foreign/tcpip/socket.h: there seems to be a problem in line 30 during compilation with the include of ”windows_config.h”. Is this correct here? Or should one [...] · View
  • Sherin Abdel Hamid joined the group Setup Support   8 years, 6 months ago · View