Hammi-Badis @hammi-badis ?

active 6 years, 4 months ago
"HI guys: sorry for the delay I was in travel, so what do I must do to install it because I use ns3.10, must I use ns3.7, other question; in the manual they demand to execute WAF with debug option [...]" · View
  • Hammi-Badis posted a new activity comment:   6 years, 9 months ago · View

    hi hanno,
    first thanks a lot for you’re reply, and for my problem I want to know the tags that I can use and how, for the stacks ”from what I read” yes we can use our stack but it needs to be programmed first.
    thanks again and have a good one

    In reply to - Hammi-Badis posted an update in the group Bug reports : Hi members, I want to install ITETRIS, so I installed Sumo and NS3, after that I Installed ICS, all works well: configure, make and install, but after that when I try to patch ns3 it shows lot of fails and when I try to do ./waf install it [...] · View
  • Hammi-Badis started the forum topic how implmenting a network stack in the group Setup Support:   6 years, 9 months ago · View

    Hi,
    I want to know how can I implement my own network stack ”ns-3 level”.
    other thing; is there any support ”documentations or rules” for the use of the different tags in the different configuration files??? ”ConfWaveVehicle.xml” for example.
    I hope get a reply and thanks a lot.
    best regards

  • Hammi-Badis posted a new activity comment:   6 years, 9 months ago · View

    Hi Hanno, I allowed my self sending you this message on an old reply because I’m really cornered, and there is no ”lot of help” although you were the only who helped me to get solutions for my problems, so I want to know how can I implement my own network stack ”ns-3 level”, is there any support ”documentations or rules” for the use of the different tags that we can use in the different configuration files??? ”ConfWaveVehicle.xml” for exemple.
    I hope get a reply and thanks a lot.
    have a good one

    In reply to - Hammi-Badis posted an update in the group Bug reports : Hi members, I want to install ITETRIS, so I installed Sumo and NS3, after that I Installed ICS, all works well: configure, make and install, but after that when I try to patch ns3 it shows lot of fails and when I try to do ./waf install it [...] · View
  • Hammi-Badis posted an update in the group Setup Support:   6 years, 9 months ago · View

    Hi,
    I want to know how can I implement my own network stack ”ns-3 level”, is there any support ”documentations or rules” for the use of the different tags that we can use in the different configuration files??? ”ConfWaveVehicle.xml” for exemple
    I hope get a reply and thanks a lot.

  • Hammi-Badis posted an update in the group Bug reports:   6 years, 9 months ago · View

    Hi,
    I want to know how can I implement my own network stack ”ns-3 level”, is there any support ”documentations or rules” for the use of the different tags that we can use in the different configuration files??? ”ConfWaveVehicle.xml” for exemple
    I hope get a reply and thanks a lot.

  • Hammi-Badis posted an update in the group Bug reports:   6 years, 9 months ago · View

    Hi,
    when I read about how Itetris wwork I saw that for making an application ”I want to make communication between vehicles a simple echo application” I must do an application module but I don’t know how to do it, so any advices or documentation is appreciated.
    thank you and have good one

  • Hammi-Badis posted an update in the group Setup Support:   6 years, 9 months ago · View

    Hi,
    when I read about how Itetris wwork I saw that for making an application ”I want to make communication between vehicles a simple echo application” I must do an application module but I don’t know how to do it, so any advices or documentation is appreciated.
    thank you and have good one

  • Hammi-Badis posted a new activity comment:   6 years, 9 months ago · View

    Hi,
    first thanks for your replay,
    for the errors, they are generated following the patch of ns-3.7.1 and yes I’m interested by your documentation, I use ubuntu 10.10 can you send me your guide to try installing ITETRIS following it advices??
    thanks a lot and have a good one

    In reply to - Hammi-Badis posted an update in the group Bug reports : Hi members, I want to install ITETRIS, so I installed Sumo and NS3, after that I Installed ICS, all works well: configure, make and install, but after that when I try to patch ns3 it shows lot of fails and when I try to do ./waf install it [...] · View
  • Hammi-Badis posted a new activity comment:   6 years, 10 months ago · View

    I tried it lot of times but without success.
    thanks for your help

    In reply to - Hammi-Badis posted an update: HI guys: sorry for the delay I was in travel, so what do I must do to install it because I use ns3.10, must I use ns3.7, other question; in the manual they demand to execute WAF with debug option ”./waf -d debug configure” and ”./waf install” after that but they don’t [...] · View
  • Hammi-Badis posted a new activity comment:   6 years, 10 months ago · View

    Hi mouhamed,
    first thanks for your help,
    before trying what you suggest me to do i’ll send you the errors that I get when I try to do the patch ”the last lines of the output”:
    Apply anyway? [n]
    Skipping patch.
    4 out of 4 hunks ignored — saving rejects to file src/routing/olsr/olsr-routing-protocol.cc.rej
    patching file src/routing/olsr/olsr-routing-protocol.h
    patching file src/test/ns3tcp/ns3tcp-socket-test-suite.cc
    patching file src/test/ns3tcp/wscript
    patching file src/wscript
    patching file utils/check-style.py
    patching file utils/utils.h
    patching file VERSION
    Hunk #1 FAILED at 1.
    1 out of 1 hunk FAILED — saving rejects to file VERSION.rej
    patching file waf-tools/shellcmd.py
    Reversed (or previously applied) patch detected! Assume -R? [n]
    Apply anyway? [n]
    Skipping patch.
    1 out of 1 hunk ignored — saving rejects to file waf-tools/shellcmd.py.rej
    patching file wscript
    patching file wutils.py

    thank you a lot and have a good one.

    In reply to - Hammi-Badis posted an update: HI guys: sorry for the delay I was in travel, so what do I must do to install it because I use ns3.10, must I use ns3.7, other question; in the manual they demand to execute WAF with debug option ”./waf -d debug configure” and ”./waf install” after that but they don’t [...] · View
  • Hammi-Badis posted a new activity comment:   6 years, 10 months ago · View

    HI,
    thanks a lot for your reply but I did exactly what like you said but when I try to build ns-3 after the patch, it shows errors ”below”
    other question, please can you tell me how can I know that I installed well my ITETRIS,

    Build failed
    -> task failed (err #1):
    {task: cxx c2c-list-routing.cc -> c2c-list-routing_1.o}
    -> task failed (err #1):
    {task: cxx olsr-routing-protocol.cc -> olsr-routing-protocol_1.o}

    thanks a lot and have a good one

    In reply to - Hammi-Badis posted an update: HI guys: sorry for the delay I was in travel, so what do I must do to install it because I use ns3.10, must I use ns3.7, other question; in the manual they demand to execute WAF with debug option ”./waf -d debug configure” and ”./waf install” after that but they don’t [...] · View
  • Hammi-Badis posted an update:   6 years, 10 months ago · View

    HI guys:
    sorry for the delay I was in travel,
    so what do I must do to install it because I use ns3.10, must I use ns3.7,
    other question; in the manual they demand to execute WAF with debug option ”./waf -d debug configure” and ”./waf install” after that but they don’t say in which directory, if it’s the ns-3 directory it will do anything without patch because it will be ns-3 building normally.
    if there is any advices or other tutorials for how to install ITETRIS i’ll be really thankfull.
    thanks and have a good one, I wish get a fast reply .

    • Avatar Image
      Muhammad-Arafat · 6 years, 10 months ago

      Hello Hammi,

      using ns3.7 is a must.

      here’s a quick tutorial of what you need to do:(remember using root user privileges)
      1) build ns3.7
      – you may use the python script ./build.py in the main folder of ns-3 (typically named ns-allinone-3.7)
      – or you may use waf commands you mentioned in ur post inside the folder(ns-allinone-3.7/ns-3.7/ )

      2) patch the installed ns: (inside the same folder where you could use ”waf”).

      3) rebuild ns3: but this time USING waf commands.

      Good Luck..

      Note: if you want to uninstall your ns3.10, I think you can use ./waf uninstall

      • Avatar Image
        Hammi-Badis · 6 years, 10 months ago

        HI,
        thanks a lot for your reply but I did exactly what like you said but when I try to build ns-3 after the patch, it shows errors ”below”
        other question, please can you tell me how can I know that I installed well my ITETRIS,

        Build failed
        -> task failed (err #1):
        {task: cxx c2c-list-routing.cc -> c2c-list-routing_1.o}
        -> task failed (err #1):
        {task: cxx olsr-routing-protocol.cc -> olsr-routing-protocol_1.o}

        thanks a lot and have a good one

        • Avatar Image
          Muhammad-Arafat · 6 years, 10 months ago

          Hello again,
          the errors ns-3 is facing are probably due to C++ compiler version, try the following commands:
          CXX=”g++-4.4” ./waf -d debug configure
          and
          CXX=”g++-4.4” ./waf install

          As for how would you know if you had well installed your iTETRIS, you may try to build the demo app provided with the platform. You will face some problems, however most of them have been covered within this community.

          Good Luck,

          Muhammad

          • Avatar Image
            Hammi-Badis · 6 years, 10 months ago

            Hi mouhamed,
            first thanks for your help,
            before trying what you suggest me to do i’ll send you the errors that I get when I try to do the patch ”the last lines of the output”:
            Apply anyway? [n]
            Skipping patch.
            4 out of 4 hunks ignored — saving rejects to file src/routing/olsr/olsr-routing-protocol.cc.rej
            patching file src/routing/olsr/olsr-routing-protocol.h
            patching file src/test/ns3tcp/ns3tcp-socket-test-suite.cc
            patching file src/test/ns3tcp/wscript
            patching file src/wscript
            patching file utils/check-style.py
            patching file utils/utils.h
            patching file VERSION
            Hunk #1 FAILED at 1.
            1 out of 1 hunk FAILED — saving rejects to file VERSION.rej
            patching file waf-tools/shellcmd.py
            Reversed (or previously applied) patch detected! Assume -R? [n]
            Apply anyway? [n]
            Skipping patch.
            1 out of 1 hunk ignored — saving rejects to file waf-tools/shellcmd.py.rej
            patching file wscript
            patching file wutils.py

            thank you a lot and have a good one.

            • Avatar Image
              Muhammad-Arafat · 6 years, 10 months ago

              Honestly, I don’t know if I can get you out of this. But I did face such problems before and a fresh installation worked out for me pretty well..

              Sorry.

              • Avatar Image
                Hammi-Badis · 6 years, 10 months ago

                I tried it lot of times but without success.
                thanks for your help

            • Avatar Image
              Hanno-Spijker · 6 years, 9 months ago

              The errors which you get when applying the patch are most likely due to patching the wrong NS-3 version. You should use ns-allinone-3.7 all other versions won’t work. Since you are getting not so many errors I think you used ns-allinone-3.7.1 ?

              I’ve wrote an installation guide for Ubuntu 10.04 since I also had to solve some problems. The installation guide provided did not always work for me. If you are interested in my installation guide, please let me know.

  • Hammi-Badis posted an update in the group Bug reports:   6 years, 10 months ago · View

    Hi members,
    I want to install ITETRIS, so I installed Sumo and NS3, after that I Installed ICS, all works well: configure, make and install, but after that when I try to patch ns3 it shows lot of fails and when I try to do ./waf install it fails.
    any help is appreciated
    thanks

    • Avatar Image
      Muhammad-Arafat · 6 years, 10 months ago

      Hi Hammi,

      First you need to make sure that you are applying the patch with an admin privileges. you can try ”sudo”, I, myself, would rather use ”su”

      then you have to apply the patch in the following folder:
      /ns-3.7/

      Good Luck..

      • Avatar Image
        Muhammad-Arafat · 6 years, 10 months ago

        the folder is:
        (path_to_ns3_main_folder)/ns-3.7/

    • Avatar Image
      Hanno-Spijker · 6 years, 10 months ago

      The patch only worked for ns-3.7 (which is not stated in the documentation). Are the latest versions of ns-3 not supported?

      • Avatar Image
        Hammi-Badis · 6 years, 9 months ago

        Hi,
        first thanks for your replay,
        for the errors, they are generated following the patch of ns-3.7.1 and yes I’m interested by your documentation, I use ubuntu 10.10 can you send me your guide to try installing ITETRIS following it advices??
        thanks a lot and have a good one

        • Avatar Image
          Hanno-Spijker · 6 years, 9 months ago

          You should not use ns-3.7.1. Use ns-3.7 instead, it is for download here: http://www.nsnam.org/release/ns-allinone-3.7.tar.bz2

          The installation guide (which I’ve written after I installed everything) is available here:
          http://hannos.nl/download/get/itetris-installation-guide/21.html

          Please note that I didn’t test the installation guide. So if you encounter errors in the document, please let me know.

          • Avatar Image
            Hammi-Badis · 6 years, 9 months ago

            Hi Hanno, I allowed my self sending you this message on an old reply because I’m really cornered, and there is no ”lot of help” although you were the only who helped me to get solutions for my problems, so I want to know how can I implement my own network stack ”ns-3 level”, is there any support ”documentations or rules” for the use of the different tags that we can use in the different configuration files??? ”ConfWaveVehicle.xml” for exemple.
            I hope get a reply and thanks a lot.
            have a good one

            • Avatar Image
              Hanno-Spijker · 6 years, 9 months ago

              The problem of iTETRIS is, I think, that it is not easy to configure. I think you can just use the c2c stack as they have implemented it in ns-3. You can implement your own tags as usual in ns-3, I think. I’m not an ns-3 expert so I cannot help you much, sorry.

              • Avatar Image
                Hammi-Badis · 6 years, 9 months ago

                hi hanno,
                first thanks a lot for you’re reply, and for my problem I want to know the tags that I can use and how, for the stacks ”from what I read” yes we can use our stack but it needs to be programmed first.
                thanks again and have a good one

  • Hammi-Badis posted an update:   6 years, 10 months ago · View

    Hi members,
    I want to install ITETRIS, so I installed Sumo and NS3, after that I Installed ICS, all works well: configure, make and install, but after that when I try to patch ns3 it shows lot of fails and when I try to do ./waf install it fails.
    any help is appreciated

  • Hammi-Badis joined the group Bug reports   6 years, 10 months ago · View

  • Hammi-Badis posted an update in the group Setup Support:   6 years, 10 months ago · View

    Hi members,
    I want to install ITETRIS, so I installed Sumo and NS3, after that I Installed ICS, all works well: configure, make and install, but after that when I try to patch ns3 it shows lot of fails and when I try to do ./waf install it fails.
    any help is appreciated

  • Hammi-Badis joined the group Setup Support   6 years, 10 months ago · View

  • Hammi-Badis commented on the blog post iTETRIS platform is already available!   6 years, 12 months ago · View

    hi,
    can you please send me the link to download the itetris platform. thank you